Email Deliverability Delayed
Incident Report for Táve
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 15:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 05, 2021 - 14:47 EDT
Investigating
We are currently noticing that emails sent both manually and automated are experiencing long queue times. Our team is actively investigating this issue.

Emails stuck in 'Queued' will not need to be recreated, Táve will process them, though the process time is delayed.
Posted Apr 05, 2021 - 14:29 EDT
This incident affected: Email.