Subscription Manager
Incident Report for Táve
Resolved
This incident has been resolved.
Posted Aug 14, 2019 - 13:02 EDT
Investigating
We are investigating an issue with the subscription manager not accepting credit cards.
Posted Aug 14, 2019 - 12:00 EDT
This incident affected: Táve Web App and Braintree API.