Square Payment Method Form Issues
Incident Report for Tave
Resolved
Square has resolved the issue with payment forms, and details of the Square incident can be found here: https://www.issquareup.com/incidents/5ks0998lwk2q.

Square's general Status can be found here: https://www.issquareup.com/
Posted Aug 17, 2022 - 19:15 EDT
Update
Square is investigating the cause of the issue and has updated their status page, which can be located here: https://www.issquareup.com/incidents/5ks0998lwk2q
Posted Aug 17, 2022 - 18:06 EDT
Update
Square has been made aware of the issue and is currently investigating.
Posted Aug 17, 2022 - 16:52 EDT
Investigating
We are investigating reports of clients being unable to enter credit card information on the Payment Form for Square Payment Methods.

If you are experiencing this, please email Support at support@tave.com
Posted Aug 17, 2022 - 16:42 EDT
This incident affected: Payment Gateways.