Slow or Timed-out Pages on the Dashboard and Job Schedule
Incident Report for Tave
Resolved
Be sure to check out our new weather features powered by the new service, including brand new weather tokens for events. We can't wait to see what you do with this new weather service!
Posted Mar 23, 2023 - 08:56 EDT
Monitoring
We've released the replacement for Dark Sky, and are monitoring the result and impact on page performance.
Posted Mar 23, 2023 - 08:56 EDT
Identified
Dark Sky, which we use for weather forecasting, is experiencing intermittent timeouts ahead of Apple shutting down the service on March 31st after acquiring it several years ago. As a result, we've seen reports that certain pages like the homepage and Job Schedule are experiencing intermittent slowdowns or timeouts.

If you're having trouble signing in because of the homepage issue, try signing in at https://tave.app/settings

As it happens, we're replacing Dark Sky with a new weather API on the morning of Thursday, March 22nd, which includes a 3-second timeout on weather lookups to avoid this sort of issue when the Weather API is down.
Posted Mar 22, 2023 - 12:55 EDT
This incident affected: Táve System.