Emails Getting Stuck in Queue
Incident Report for Tave
Resolved
A fix has been implemented and our Team believes this issue to now be resolved. If you continue to have emails stuck in the 'queued' status, please reach out to our Support Team directly.
Posted Apr 19, 2021 - 15:01 EDT
Update
We are continuing to investigate this issue.
Posted Apr 19, 2021 - 14:28 EDT
Investigating
We've had reports of emails getting stuck in 'queued' state. We are actively investigating this incident. Please avoid resending emails for now to avoid potential issues with duplicate emails.
Posted Apr 19, 2021 - 14:02 EDT
This incident affected: Email.